Engine error placing mill for cook

Title: Boulderboy’s super-awesome-fantastic bug report (or: The day I learned to format)
Summary:

Multiple engine errors when I attempted to place the stone mill for the cook

Steps to reproduce:

  1. make stone mill

  2. attempt to place

3)write bug report

Expected Results:

Place the mill, make food for live stock

Actual Results: 7 errors pasted below

Error 1)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:104: in function ‘_unknown_transition’
stonehearth/components/ai/execution_frame.luac:191: in function ‘_add_action’
stonehearth/components/ai/execution_frame.luac:561: in function ‘fn’
stonehearth/services/server/threads/thread.luac:109: in function ‘private_msg’
stonehearth/services/server/threads/thread.luac:168: in function ‘_dispatch_messages’
stonehearth/services/server/threads/thread.luac:128: in function ‘suspend’
stonehearth/components/ai/execution_frame.luac:659: in function ‘wait_until’
stonehearth/components/ai/execution_frame.luac:348: in function <stonehearth/components/ai/execution_frame.luac:348>
[C]: in function ‘xpcall’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 2)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
stonehearth/services/server/ai/compound_action.luac:125: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’
stonehearth/components/ai/execution_frame.luac:451: in function ‘_start_from_ready’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 3)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
stonehearth/services/server/ai/compound_action.luac:125: in function ‘start’
stonehearth/ai/actions/loop_action.luac:56: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 4)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
stonehearth/services/server/ai/compound_action.luac:125: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’
stonehearth/components/ai/execution_frame.luac:451: in function ‘_start_from_ready’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 5)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
…onehearth/services/server/tasks/run_task_action.luac:56: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’
stonehearth/components/ai/execution_frame.luac:451: in function ‘_start_from_ready’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 6)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
stonehearth/services/server/ai/compound_action.luac:125: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’
stonehearth/components/ai/execution_frame.luac:451: in function ‘_start_from_ready’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Error 7)

<develop-2617 (x64)
stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:688: stonehearth/components/ai/execution_frame.luac:104: bad frame transition “add_action” from “starting”
stack traceback:
stonehearth/components/ai/execution_frame.luac:672: in function <stonehearth/components/ai/execution_frame.luac:665>
[C]: in function ‘error’
stonehearth/components/ai/execution_frame.luac:688: in function ‘_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:683: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:348: in function ‘start’
stonehearth/services/server/ai/compound_action.luac:125: in function ‘call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function ‘_call_start’
stonehearth/components/ai/execution_unit_v2.luac:226: in function ‘_do_start’
stonehearth/components/ai/execution_unit_v2.luac:196: in function ‘_start_from_ready’
stonehearth/components/ai/execution_unit_v2.luac:132: in function ‘_start’
stonehearth/components/ai/execution_frame.luac:508: in function ‘_unwind_call_stack’

stonehearth/components/ai/execution_frame.luac:129: in function ‘_run’
stonehearth/components/ai/execution_frame.luac:360: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function ‘xpcall’
stonehearth/components/ai/execution_frame.luac:674: in function ‘_protected_call’
stonehearth/components/ai/execution_frame.luac:362: in function ‘run’
stonehearth/components/ai/ai_component.luac:178: in function ‘_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function ‘xpcall’
stonehearth/services/server/threads/thread.luac:89: in function ‘f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>>

Notes: noted

Attachments: Log file to be attached to post

Versions and Mods: A12 Dev 2617(x64)

Debugging tools only

System Information:
Windows 10 x64 home
12GB DDR3 RAM
Intel Core i7-3630QM @ 2.4GHz
Primary graphics processor: Nvidia GT650M w/ 1 GB GRAM
Secondary (inactive) graphics processor: Intel HD4000 integrated graphics chip
All drivers update automatically and are checked daily.

stonehearth.log (2.5 MB)

Anyone else getting this? I can’t seem to make it happen.

I have only had it happen the one time, i have placed several since then with no issue so it seems to be a rare beast :\