Engine Error on Launch and Poor Performance

Every time I attempt to boot into the game it has this exact same problem pop up. Originally I had to use Compatibility mode and set it to Windows 8 to get it to even boot. Then firewall was causing problems so I resolved it. Once that was fixed Kapersky flagged it as flawed and I had to troubleshoot that and finally got it fixed. After that I had opened it to a black screen with music and have to press F5 to get into the game every time. I thought bug hell was finally over but now once I boot the game the performance is abysmal and I’m getting Engine Errors. I had played this game successfully a few years back but now it absolutely refuses to work.

Here’s the bug titled “Engine Error” that continues to pop up when the game is launched.


release-949 (x64)[M]
...ce/monkey_patches/ace_collect_starting_resources.lua:7: attempt to call field '__userdestroy' (a nil value)
stack traceback:
	[C]: in function '__userdestroy'
	...ce/monkey_patches/ace_collect_starting_resources.lua:7: in function '__user_destroy'
	stonehearth_ace/radiant/lib/unclasslib.lua:293: in function <stonehearth_ace/radiant/lib/unclasslib.lua:285>
	[C]: in function 'destroy'
	...ct_starting_resources/collect_starting_resources.lua:190: in function <...ct_starting_resources/collect_starting_resources.lua:188>

The second error report that game up was the following:

release-949 (x64)[M]
c++ exception: lua runtime error
stack traceback:
	[C]: in function 'destroy'
	...ct_starting_resources/collect_starting_resources.lua:190: in function <...ct_starting_resources/collect_starting_resources.lua:188>


This is my first time ever posting a topic here so I'm unsure if I've done what's expected properly but I apologies if there's any errors. For the final piece my Id is user_id is a0b6bc20-abb2-465d-b581-53ba816ad227

I would add my stonehearth.log file but I'm currently unable to due to character limit.

If you are on windows 10, you can remove all your antivirus and use windows default which is as good as those nowadays anyway, without the performance drop they have.
This game suffers a lot from antivirus, they can hog the game performance on a never ending scanning files loop

2 Likes

As of now there’s still a performance issue but there’s no longer an issue popping up for the Engine. I’ve now uninstalled Kapersky and activated Windows Antivirus.

This has solved my problem so I believe this is probably the end. Thank you very much.

2 Likes