Engine Error: invalid entity reference

2015-Jun-27 10:19:56.821134 | server | 1 | lua.code | generating traceback…
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | – Script Error (lua) Begin -------------------------------
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | std::logic_error: 'invalid entity reference in get_standable_point’
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | stack traceback:
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | [C]: ?
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | [C]: in function 'get_standable_point’
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | radiant/modules/terrain.luac:47: in function 'get_standable_point’
2015-Jun-27 10:19:56.821134 | server | 0 | lua.code | …spawn_region_finder/spawn_region_finder_service.luac:55: in function 'try_spawn’
2015-Jun-27 10:19:56.822134 | server | 0 | lua.code | …spawn_region_finder/spawn_region_finder_service.luac:61: in function <…spawn_region_finder/spawn_region_finder_service.luac:56>
2015-Jun-27 10:19:56.822134 | server | 0 | lua.code | – Lua Error End -------------------------------

Could you elaborate a bit more, please? :sweat_smile:
Which version were you playing when this error happened? What was going in-game when it popped?

The version was alpha_10_5 10 x64 build.

I was using the custom building tool to make roads.

1 Like

Almost the same here. But occured while clicking on build for the “upgraded worker outfit” in the weavers shop.

Version: Alpha 10_5-10 x64

1 Like