[d-1633] Moving table crushes the game


#1

After setting up a table somewhere, if I try to move it somewhere else, the game crashes for me. I made another game and the bug repeated easily.


[Dup] Game crashing when moving placed object
[Dup] Alpha 5, D1633 - C++ Exception
#2

Confirmed, only happends with the regular dining table tho, the table for one works fine.

here’s the error I got:


#3

Title: Alpha 5, D1633 - C++ Exception

Summary: I loaded a previous save for my town and when I tried to move a dining table to make room for a house I got an C++ error.

Steps to reproduce:

  1. Load a previous save of a town
  2. Move an object (in my case, a dining table)

Expected Results: table gets moved

Actual Results: c++ error and AI crashes.

Attachments:

Versions and Mods: Alpha 5, D1633. No Mods.

System Information: Win7 Pro x64, Nvidia GTX 560 Ti, 16gb ram


#4

I also had this problem when trying to move picket fences.


#5

I can second this also. Tried to move a fence to place a gate and it bombed.


#6

When any object that I have already placed once and try to move the game then crashes shortly afterwards. Not sure if this has been reported yet.


#7

Can’t reproduce this here in 1658 (which version are you running BTW?), but is it a particular object? Fence gates etc have caused issues before now…


#8

Never mind it has already been discussed. I get these same error codes.

Yes 1658 and it is when I move fences and dinner tables.