Custom crafting class


#42

Great thank you guys both! I will give it a try here in a bit!


#43

Just remember there are also no animations and such - we’re coming up with these for ACE too, so maybe it might be interesting to make your offhand weapons ACE dependent :slight_smile:


#44

Is the code you put up the ACE support, or is there something else? I am making my own class with all new armor, clothes, and weapons and I want it to be as compatible as possible with everything else.

BTW congrats on 20,000 ACE downloads in like 3 days! I am playing it and making sure my stuff is compatible and it is pretty f-ing awesome!!!


#45

An ACE off-hand weapon looks like this:

"stonehearth:equipment_piece": {
         "slot": "offhand",
         "render_type": "attach_to_bone",
         "additional_equipment": {
            "stonehearth_ace:armor:offhand_placeholder": true
         },
         "postures": [
            "stonehearth:combat",
            "stonehearth:patrol"
         ],
         "ilevel": 8,
         "roles": [
            "footman_job"
         ],
         "required_job_level": 1,
         "equip_effect": "stonehearth:effects:weapon_level_up",
         "equipment_types": [
            "offhand_weapon"
         ]
      }

The new things are:
"stonehearth_ace:armor:offhand_placeholder": true our placeholder. It is a placeholder for the “leftArm” slot because we also mix the default placeholder to be an actual “offhand” slot placeholder. So vanilla weapons won’t accept offhand items and off-hand weapons won’t accept vanilla/old mods leftarm weapons :smiley:

And this bit here:

"equipment_types": [
                "offhand_weapon"
             ]

Is part of our new equipment preference system. Units have toggle buttons where you can choose what they’ll use (one-handed + shield, two-handed, dual-weild, etc…) and these filters are the ones used to determine what is what.

These will make your offhand work with ACE’s offhand system. But like I said, I’d recommend locking them out if ACE is not active unless you also create all the other things like animations and such :frowning:

Well, thanks :smiley: It’s a bit easier to achieve that when the game automatically subscribes to ACE when you enter it, though - which is the case :jubilant: So these numbers doesn’t really mean much, the feedback we’re getting (good or bad) is what is really worth it :merry:


#46

Well I love he new weapon selection tool you guys implemented. That’s what started this whole day! See something new and strive to make what you have comparable or at least compatible. Thanks for making all of us strive to be better. You and your whole team!


#47

I’m back!
I am trying to make a “fixer” mod for the awesome Wizards mod. I have already fixed the typos relating to task_group(s) and the Blue Wizard crash. My problem now is that the Artificer Job button is greyed out and the text says “Requires an Artificer”:


As you can see, there IS an Artificer. Can someone take a look and not just fix it, but teach me what the problem is? This really does relate to the topic I’m posting under!
Here are the files in question:
wizard_fixer.smod (4.0 KB)
wizards.smod (734.4 KB)
The first file is the fixer for the wizards mod. The second is the wizards mod. That is where the Artificer problem is. I intend on putting the fix in a mixinto or overrides.
I hope this makes sense!
Thanks!
-Tacocat
edit- If you click on the workshop icon over there under Alaina Winset (the anvil) it does bring up the crafter menu, and she does complete the crafting orders.


#48

I can guess right now, that the button is not referring to the Artificer class. Same happened to me when first setting up my Cleric and Necromancer crafting.


#49

@tacocat Wizards mod doesn’t have a namespace at all… :man_facepalming: so I don’t know how a lot of the mod is going to work. it can’t look for “wizards:jobs:artificer” since it doesn’t know what “wizards” even is… I don’t know if you could mixinto their manifest with a new one in yours that simply adds the namespace to their mod. haha idk


#50

actually, I just tried that on my end and didn’t fix it… I even added the namespace into the wizards manually just to test and it still didn’t work. I kept getting an error for taskgroups or something whenever promoting the artificer. it must be something there but I didn’t have time to look right now.


#51

namespace is a very recent addition. Without it the mod uses the name field. It was created so modders could have a nicer name displayed instead of the mod_x123 in the code


#52

so without namespace it uses name as the mod prefix then? hmm then I’m still not sure why it won’t recognize “wizards:jobs:artificer” as being active and allow you to click on the workshop button.


#53

So where did you find the fix when you were setting up your custom classes?


#54

I figured it out. I didn’t put the artificer info in my manifest. That will keep it from applying the changes! At any rate I’m uploading the A22 .smod and the fixer mod over on the wizards thread now. Thanks!