Custom crafting class


#35

Another quick question…
If I remove the recipe aliases from my manifest, is there an easy way to edit them in SHED?
(Like the way you suggested using the iconic tab of an entity).
Writing the en.json is my worst!


#36

Only if their crafter is a declared job in the manifest. For example, your Guildmaster recipes will always show on shed as sub-items of your Guildmaster job, even if you remove them from the manifest.

Recipes that were added to other professions, however, won’t. Editing things in SHED is really easier, so just remove the Guildmaster recipes (which should make up most of the mod recipes anyway) since they’ll remain in SHED nonetheless and only leave the recipes that belongs to other professions, so it is easy to edit :slight_smile:


#37

Here’s the updated .smod . Still no new models.

weapons_plus.smod (1.1 MB)

But… I don’t need drop box anymore!
Thanks to your suggestion the unzipped mod went from 406 mb to 3.14 mb after cleaning!
Now a few days of design and modelling to fill up the recipes!

On a completely related subject, you know how when you get a buff your stats turn green? Can you do that with the description of an item? (for example Speed +20 in green (Like some other games use .)) To emphasize that it is a “magical” item?

Thank you for all your help today!
-TacocaT


#38

So i have made a couple of weapons and am trying to make some dual wield weapons now. The problem I am having is when I put

"slot": "mainhand",
"slot": "offhand"

They still have a shield also, which is not the effect I was going for.
So I looked at the shield.json and saw it is

"slot": "leftArm"

So I added that into my weapon.json. Now they drop the shield but attach the weapon to the left arm and not the left hand.
My question is how to tell it NOT to pick up a shield but also NOT attach a sword to your left forearm?


#39

Each slot can only have 1 item in it.
When the game is reading your file, it will read only one of the “slot” fields. You can’t have two fields with the same name in a json file because the lua reading it only sees one.


#40

So if I want them to carry 2 daggers I need to make a recipe/entity for dagger.json and dagger_offhand.json (for example, and with all the dependant files) then declare dagger.json “mainhand” and dagger_offhand.json “offhand”?


#41

Yes, this is something we dealed with in ACE by standarizing all offhand items to the offhand slot. We made it in a way that is retro-compatible with shields from other mods, but if you want to make an off-hand weapon that is compatible with SH shield system without having to come up with a lot of new things, make your off-hand weapon “offhand” slot but also add to it the “added equipment” for the offhand placeholder like shields and two handed weapons do, like this:

"stonehearth:equipment_piece": {
         "slot": "offhand",
         "additional_equipment": {
            "stonehearth:armor:offhand_placeholder": true
         }

That way the weapon will be equipped in the offhand and no shield will be able to be equipped with it :slight_smile:
The only issue is that without altering the equipment preferences, footmen will be crazy equipping shields and then offhand weapons back and forth since they’re two different slots.

So you need to add proper support for offhand weapons by making units choose either shields or them - or just use ACE’s support :slight_smile:


#42

Great thank you guys both! I will give it a try here in a bit!


#43

Just remember there are also no animations and such - we’re coming up with these for ACE too, so maybe it might be interesting to make your offhand weapons ACE dependent :slight_smile:


#44

Is the code you put up the ACE support, or is there something else? I am making my own class with all new armor, clothes, and weapons and I want it to be as compatible as possible with everything else.

BTW congrats on 20,000 ACE downloads in like 3 days! I am playing it and making sure my stuff is compatible and it is pretty f-ing awesome!!!


#45

An ACE off-hand weapon looks like this:

"stonehearth:equipment_piece": {
         "slot": "offhand",
         "render_type": "attach_to_bone",
         "additional_equipment": {
            "stonehearth_ace:armor:offhand_placeholder": true
         },
         "postures": [
            "stonehearth:combat",
            "stonehearth:patrol"
         ],
         "ilevel": 8,
         "roles": [
            "footman_job"
         ],
         "required_job_level": 1,
         "equip_effect": "stonehearth:effects:weapon_level_up",
         "equipment_types": [
            "offhand_weapon"
         ]
      }

The new things are:
"stonehearth_ace:armor:offhand_placeholder": true our placeholder. It is a placeholder for the “leftArm” slot because we also mix the default placeholder to be an actual “offhand” slot placeholder. So vanilla weapons won’t accept offhand items and off-hand weapons won’t accept vanilla/old mods leftarm weapons :smiley:

And this bit here:

"equipment_types": [
                "offhand_weapon"
             ]

Is part of our new equipment preference system. Units have toggle buttons where you can choose what they’ll use (one-handed + shield, two-handed, dual-weild, etc…) and these filters are the ones used to determine what is what.

These will make your offhand work with ACE’s offhand system. But like I said, I’d recommend locking them out if ACE is not active unless you also create all the other things like animations and such :frowning:

Well, thanks :smiley: It’s a bit easier to achieve that when the game automatically subscribes to ACE when you enter it, though - which is the case :jubilant: So these numbers doesn’t really mean much, the feedback we’re getting (good or bad) is what is really worth it :merry:


#46

Well I love he new weapon selection tool you guys implemented. That’s what started this whole day! See something new and strive to make what you have comparable or at least compatible. Thanks for making all of us strive to be better. You and your whole team!


#47

I’m back!
I am trying to make a “fixer” mod for the awesome Wizards mod. I have already fixed the typos relating to task_group(s) and the Blue Wizard crash. My problem now is that the Artificer Job button is greyed out and the text says “Requires an Artificer”:


As you can see, there IS an Artificer. Can someone take a look and not just fix it, but teach me what the problem is? This really does relate to the topic I’m posting under!
Here are the files in question:
wizard_fixer.smod (4.0 KB)
wizards.smod (734.4 KB)
The first file is the fixer for the wizards mod. The second is the wizards mod. That is where the Artificer problem is. I intend on putting the fix in a mixinto or overrides.
I hope this makes sense!
Thanks!
-Tacocat
edit- If you click on the workshop icon over there under Alaina Winset (the anvil) it does bring up the crafter menu, and she does complete the crafting orders.


#48

I can guess right now, that the button is not referring to the Artificer class. Same happened to me when first setting up my Cleric and Necromancer crafting.


#49

@tacocat Wizards mod doesn’t have a namespace at all… :man_facepalming: so I don’t know how a lot of the mod is going to work. it can’t look for “wizards:jobs:artificer” since it doesn’t know what “wizards” even is… I don’t know if you could mixinto their manifest with a new one in yours that simply adds the namespace to their mod. haha idk


#50

actually, I just tried that on my end and didn’t fix it… I even added the namespace into the wizards manually just to test and it still didn’t work. I kept getting an error for taskgroups or something whenever promoting the artificer. it must be something there but I didn’t have time to look right now.


#51

namespace is a very recent addition. Without it the mod uses the name field. It was created so modders could have a nicer name displayed instead of the mod_x123 in the code


#52

so without namespace it uses name as the mod prefix then? hmm then I’m still not sure why it won’t recognize “wizards:jobs:artificer” as being active and allow you to click on the workshop button.


#53

So where did you find the fix when you were setting up your custom classes?


#54

I figured it out. I didn’t put the artificer info in my manifest. That will keep it from applying the changes! At any rate I’m uploading the A22 .smod and the fixer mod over on the wizards thread now. Thanks!