[Con] Footmen don't equip weapons & armor

I havethis exact same issue on Version 8 64-bit

So I had the same problem. I made a mace, a couple swords, some armor, and shields, but none of the footmen would pick them up. They were all in a large stock pile, I moved them to a smaller stock pile just for weapons and armor. All of my footmen sprinted over and upgraded their gear.

1 Like

@thisdrino which build? 205 stable or 2143 unstable x64 or x86? its important for the devs :wink:

I’m on the 2143 unstable x64

Ok so here has been my experience with this bug. I get a red error message in the top left (no screenshot yet, will post one later if I find time). This message appears whenever I craft something, maybe at the time it is placed in a stock pile or maybe it’s just right after crafting it. Either way, they then don’t pick up the upgrade unless it’s a wooden shield. In that case they DO pick it up, consistently, but they won’t grab any armor or weapons. Old veteran footmen and new footmen who just joined my town, doesn’t seem to matter. They won’t pick up the stockpiled pike, in a tiny stockpile, won’t pick up the steel sword in the big stockpile, won’t wear the padded or leather armor in a small stockpile. Not even when they patrol those stockpiles, still clinging to their wooden swords.

I’m running Dev2143 x64

Update: I’ve discovered items will be equipped ONLY if they are placed in a dedicated stockpile. This is the error generated EVERY time a piece of armor or a weapon is placed in any stockpile.

2015-Feb-07 22:02:48.982249 | server | 1 | lua.code | generating traceback…
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | – Script Error (lua) Begin -------------------------------
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stonehearth/lib/entity_forms/entity_forms_lib.luac:17: attempt to index a nil value
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stack traceback:
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | [C]: in function '__index’
2015-Feb-07 22:02:48.983250 | server | 0 | lua.code | stonehearth/lib/entity_forms/entity_forms_lib.luac:17: in function 'get_uris’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/services/server/shop/sellable_item_tracker.luac:3: in function 'create_key_for_entity’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | …ehearth/services/server/inventory/inventory_tracker.luac:5: in function 'add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/services/server/inventory/inventory.luac:24: in function 'add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:142: in function '_add_item_to_stock’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:133: in function '_add_item’
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | stonehearth/components/stockpile/stockpile_component.luac:101: in function <stonehearth/components/stockpile/stockpile_component.luac:101>
2015-Feb-07 22:02:48.984252 | server | 0 | lua.code | – Lua Error End -------------------------------

I an also confirm an issue with equipping wooden bucklers got error messages 3 & 4, not sure about previous 2, as soon as my hearthies dropped the bucklers in the dedicated stock pile. I also made a wooden sword for my 2nd footman prior to the bucklers which was equipped.

Just made a dedicated light/heavy armour stockpile and my footmen still didn’t pick up the shields but… when some goblins turned up to party ONE of my footmen picked up a shield during the fight. He made one attempt went to run back to fight, changed his mind, then picked up the shield before returning to fight.
Edit: Rather than post again, game crashed so had to reload the save just before the goblins turned up. This time they didn’t pick the shields. When I made a stockpile and the shields got placed there with a recently made padded armour I thought I wonder if I convert a footman back to a worker will that work, it did they equipped the items.

What worked for me was to create a single solitary stockpile for weapons and armor. No other stockpiles allowed to have those items.

1 Like

Can’t replicate the action to re-equip, must of been a one-off. Tried a single stockpile and did not work, as soon as they drop off an item error message so I am assuming its down to an issue when a footman triggers an upgrade your equipment command. Also I am having an issue with workers upgrading to improved uniforms from the tailor.

I have been getting the same error code with the upgraded worker clothes.
64bit 2143

This happens quite often now once every 2? new maps any storage area containing new items either clothes upgraded worker or shields (any) and even the Bronze mace will cause it to happen Hearthlings will put items into the storage area but then it seems to stay there this error will also cause the game to ctd if enough of them appear

Stonehearth 0.1.0 (develop 2143) x64 build

Doh. This is due to some of the dormant code for shops. A fix is on the way in the unstable branch…

5 Likes

Thanks Tom. I appreciate you guys going out of your way to fix even stuff like this in the unstable branch.

3 Likes

I hope this fix comes fast. I keep building new Areas and I every time I go to make an upgrade for the hearthlings I get that silly error as soon as the item is placed in the stockpile

stonehearth/lib/entity_forms/entity_forms_lib luac:17:

Hi, I noticed that when a footman is downed by an enemy all their gear is dropped on the ground. After they are rescued and recuperate they return to duty but won’t re-equip any of their gear. None of the workers will move the gear to empty stockpiles either. I’ve tried placing stockpiles under the stuff but nothing will get my hearthlings to move them (at this point i just want to get rid of the stuff because I’ve already made better equipment).

use the loottool to get the hearthlings go and collect the items.

omg THANK YOU :joy: I can’t believe I didn’t think of that… I can finally clean up all the stone maces and leather armor lying around my town!

1 Like

This is still an issue 3 years later guys, please get it fixed this is a great game if it would just work as its supposed to.

Welcome to the forum, @Revjak_Revjourin. :slightly_smiling_face:

Could you please upload your savefile so that devs can take a look at it?

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Make sure the equipment you mention is in a storage, and that its player_id is correct (if you hover over it and it’s red, drag the loot tool over it so that your town claims it). Also make sure your footmen can reach it and have the required level.