Buildings with Second Floor not Finishing and Running into errors

Summary: After building blackforest inn, all but a lamp on the second floor is built. The scaffolding is still there, the lamp is ghosting as if it is queued to be built, but because a ladder left from the scaffolding goes straight through a chest, it can’t be finished. Any time I try to move the chest (by clicking on the chest and then clicking the button to have a hearthling move it somewhere), a new chest is placed instead. It seems to be pulling the chests from my inventory until I have no more chests to place, then I can just infinitely queue up more chests to place (each time I try to move the stuck one) and ghost chests appear as if in the queue. The building never finishes while this is happening.

Using the teleport command in the control panel I am able to move the chest blocking the ladder and a hearthling is able to put up the lamp (image 4-6). However the scaffolding remains. No matter what I do, the building still never seems to finish. The bug itself seems to be surrounding the duplicating chest. When I try to use the teleport command to move the chest I get an error.

Steps to reproduce:

  1. Build Blackforest Inn
  2. See if chest blocks ladder on second floor
  3. Move blocked chest around

Expected Results:

Actual Results:

Notes: Tried uploading multiple images to show my steps and to be as thorough as possible. As I’m only allowed to upload one photo as a new user, this report will not be as complete and informative as it otherwise could have been.


Version Number and Mods in use: Alpha 23. Stonehearth 0.24.0 (release 790) x64 build. No mods installed.

System Information:
Windows 10

I think it is a problem with order of placement, particularly of the lamps in buildings. Things that go under lamps are getting set down first which blocks the lamp that should go above it from being placed, thus preventing the building from being completed. I ran into the exact same problem trying to build my tavern (pictured above). The table was placed, which prevents the lamp (and ladder to place it) from being placed so it just sorts of sits there as a ghost, unable to be completed.

Update: I tried having a hearthling move the table, but it just ends up as a ghost move that no hearthling will touch. So I tried using the ‘teleport’ command prompt. I moved the table out, hearthlings built the lamp, and then I put the table back in place (hearthling on table as I poofed it in underneath her). Building still not ‘finished’ according to building designer panel. Because of moving things it says I now need 2 dining tables to finish it.