Bugs from Alpha 4

Hey folks.
Glad to see Stonehearth coming along so well. The music is beautiful and the gameplay is starting to take shape. I am really pleased to see how things are coming along. I know its way-early in development, so I just thought I’d share some of my bug experiences with the most recent Alpha.

Please note that Steam forums do not allow me to upload these screenshots as “Public” due to the game being listed as a Non-Public release as of yet, however it does state that the game creators / admins / mods should be able to view them.


I had to do this because apparently it does not allow me to post more than 2 links in a single post.

After creating a small building, I had placed 4 windows along the front side of the building along with the Door. All is well, except for the fact that the Workers absolutely and utterly refuse to remove the ladders they placed in order to place the windows. Even with no other active jobs and completely idle, they refuse to remove them no matter what.

I also have had a similar issue where I placed beds too close together and some of them appeared in mid-air. After placing ladders “up” to them in order to get them down and place them elsewhere, all Workers refused to remove those ladders afterwards, even when idle with no other active jobs.

I had placed a new building plan and construction was underway. However, one side of the building was ~1 or ~2 blocks away from some natural Berry Bushes. The Workers placed the floor tiles, but absolutely and utterly refused to build the wall there. I believe there is some invisible “no construction” zone around the Berry Bushes, even though there is in fact room to build.

Whilst playing, I got an alert for a new traveller (Worker) wanting to join the town. I accepted. Good stuff. However, whenever I accept ~ANY~ pop-up request, certain elements of the UI cease to function. Specifically, the bottom-left UI box becomes fixed on whatever text it was displaying at the time and will not change. If I click on a Carpenter for example, his Workshop buttons do not appear bottom-left as they should. Or if I click on furniture, the buttons to move or place it do not appear bottom-left.

The only fix is to save, leave game, and go back in.

Also, I stated I had accepted this new traveller (Worker) into my town. Upon reloading my game, I checked the manifest listing all people in my town and she simply was not on the list. After searching around my town for 5 minutes, I eventually found her. As soon as I clicked on her, I got a ~massive~ pop-up debug error report.

But after that she did appear in the Town Manifest again. Weird.

Double-Stacking. I had placed 3 seperate stockpiles with all items enabled, all stockpiles directly adjacent to each other (edges touching). After some time, I had noticed that people were placing items ontop of other items occupying the same slot. In the screenshot, There can be seen a Basket of Corn in the same spot as a Wood Log. There is also a Spool of Thread occupying the same spot as a Rock Chunk.

I do not have a screenshot for this, but it is not necessary.

Picket Fences and Picket-Fence Gates are completely unusuable. After being made by a Carpenter and placed in the Stockpile, there is absolutely nothing I can do to place them anywhere for actual use. When building a building or using the place-items interface, they do not appear anywhere. When clicking on the items themselves in the actual stockpile, there is no option to move or place them.

I hope there will be a way to ‘delete’ or change the ownership of items in the future. After constructing 7 “Mean Beds” for my Townspeople, I later upgraded to “Comfy Beds”. However, they still insisted on using the Mean Beds despite having 7 unoccupied Comfy Beds, which are undoubtedly better.

Also, when placing items (like Lanterns or Tables) via the construction interface, those items will remain in the list as if waiting to be placed (from a stockpile) even if they are already placed in the world. For example, if I have 1 desk in the Stockpile and I use the construction interface to place it, even after the table is placed, the interface will still say I have 1 desk waiting to be placed.

Sometimes the “placement hologram” also remains forever and the object is simply not moved by anyone, even if there are numerous idle workers and nothing waiting to be done.

One interesting problem I ran into was that of my 7 townspeople, I had 2 Footmen, 1 Weaver, 1 Carpenter, 1 Trapper and 2 Farmers. In the course of things, I was constructing a building and ran out of wood. All of my people refused to go and chop any trees down even if I ordered them to, and they had no other existing work apart from constructing the building, which they were waiting to do, since there was no wood to use.

Interestingly, my Trapper was standing around idle, wanting to build, but there was no wood to use. When I cleared all of his hunting fields, EVERYONE then finally decided to go chop the trees down for more wood to use in the construction.

Apologies for the long post, but I love Stonehearth and I am glad to see how it has come along. I hope these issues can be solved and the game goes on to be even better.

Besides, everyone already knows that I think Goblins need an adjustment. In one game, I was swarmed by 10-15 Goblins on Day 4. In another game, I have only encountered ONE goblin on Day 17.


hey there @Venrez… welcome aboard! :smile:

thanks for the very detailed Alpha 4 feedback! providing reproducible steps is immensely helpful for the team in tracking down and resolving the bugs… :+1:

ideally, we would break these out into individual reports (but I can’t fault you too much, as I’ve been known to bend that rule a time or two myself)… :wink:

happy hunting!

1 Like

Strange that you say that. Every forum I ever go to says ‘You should make multiple posts’ and then if you do, they call it spam. Or, they criticize you for not using the search function. Or they criticize you for not simply posting onto the end of a currently existing thread. But then they criticize you for doing so.

Oh well, thanks for the welcome. I just hope the Stonehearth team is able to view the screenshots detailing what I described, as I cannot make the screenshots public due to Stonehearth-on-Steam not being public-release yet.

All of them are reproducible. I’ve gone back for yet another game and encountered the exact same bugs in the same situations.

I’ve also encountered an odd problem where the game will turn to Night and thus people seek their beds. One of my Workers was busy chopping a tree, when he suddenly stopped and did the ‘yawn-and-stretch’ animation. He then immediately laid down where he was standing by the tree to sleep.

Only to then teleport about 100 metres to the bed he had claimed.

Next night-time, he refused to sleep in the bed that was previously his. No-one else would use it either. Even with multiple spare beds, he would simply sleep on the ground and then complain.

1 Like

Welcome from me as well! :slight_smile:

This post contains some links to places where issues you described were already discussed, so that you may find more information and conversation about it, and there’s back and forth linking between those topics and this one.

Well, it is encouraged to use the search function here as well to try and prevent too many duplicate threads, obviously. However, though I’ve failed to find an earlier topic on a given subject a few times, I wouldn’t say I was ever really criticized. They always just pointed it out to me, merged the topics in question, and more or less said that it was okay :smile:

As for separate threads for bug reports, that is also encouraged so as to make it easier to discuss the issues. With multiple bugs in one thread, it’s not only harder to retrieve the separate bugs using the search function, it also could mean many conversational threads in a single topic.

I noticed this as well. Thanks for the reminder. I made this topic about the issue.

That’s because of this issue; you shouldn’t need to place ladders in order to move them though. When this happens to me, my citizens can reach them just from the ground. Maybe that will help in future games.

That’s this issue; however, I’ve noticed it in particular when accepting joining citizens. So you’re saying it would happen also when you accept trade requests, for example? However, come to think of it, you always get a request to be given some food (usually) at the start, and I know that the freeze does not happen when you accept that.

Yes, that will still happen sometimes. In my latest game, it was cloth being placed repeatedly on top of jerky.

They were purposefully disabled by the developers until they work out the issue with items near each other hovering, like with the beds you mentioned above.

Indeed! I made a suggestion to change this here.

I hope so too. The bed issue was brought up here.

Was the order to move it to a place rather close by the original place of the item, perhaps?

Wow! That’s very interesting, I’ll have to try that when I have idling citizens next time.

Yes, the current situation with the sudden attack waves was very much unintended.

1 Like

My workers would not retrieve the beds. I had to place ladders. The further issue however is that 4 beds appeared in midair, due to being placed too close together as we know. However afterwards, I was able to remove 2 of the ladders. Yet 2 remained and the Workers would never, ever, take them down.

Further to this point, 1 ladder was on the “head” side of the bed and couldnt be taken down, and 1 ladder was on the side, and couldnt be taken down. Yet 2 others, as I’ve described, were taken down - so I have no idea.

Yes. Every single time I get a trade request, or someone wants to join my town, or a ‘A Goblin is Stealing your Stuff!’ alert pops up - if I click on the Alert to respond to it, certain parts of the UI will cease to function.

Although I actually dont know about being given food right at the start of games. That’s never happened. Its always some nobhead who wants 16 chairs for a fireplace or some rubbish :stuck_out_tongue:

If I ignore the Alert and dont respond to it, nothing happens. But that shouldnt mean I have to deny myself future citizens, trading or Alerts altogether.

Either close or, just to see what happened, I put the placement hologram miles away. Either way, the Workers would refuse to do anything about it and the hologram would remain forever.

1 Like

I was in the process of building a house with 7 beds. It was mostly complete, but the scaffolding hadn’t yet been taking down when all seven citizens decided it was naptime. They managed to get in the house, but now they are all trapped and can’t find a way out. I do have the save if you’d like it.

if they have any wood inside the house, you can try to toss up a ladder, and see if they can get out that way…