Bug List Alpha 4, Release 0.1.0, Build 134

A pathfinding related bug screen

Bug with the placing of tools inside stocking piles, consequence: quest failed

I had a Fur Rug in last position in my crafting queue. I decided to erase it from the queue because I wanted to craft 5 instead of 1. After I dragged the icon on the trash, the Fur Rug icon was still in queue. So I dragged it again on the trash, this time it disappeared from the queue but I got a bug window (upper-right corner of the screen).

1 Like

This time I wanted to build a very big L house. In the design window I draw the L floor, saw that the firepit would be too close to the future house, so I clicked on it directly without leaving the design window, and 2 bug windows appeared.
Also notice the UI bug at the bottom left.

1 Like

Looks like I got a lot of work to add to the list :wink:
I’ll get right on it, thanks all :slight_smile:

My guys have become evil. There was a wood block on the roof, and when loading a save they always build scaffolding on the already-built building, locking on occupants inside. They do get the wood block, though.

No idea what crimes were committed…



Could have potentially doubled up the building… Maybe it tried to build a single wall again, but couldn’t, so they stopped after they made the scaffolding?

No this happened to me too. (In r129). In my case they rebuilt the scaffolding on a building they had previously stolen a window from to use elsewhere… it was an interesting couple hours of playtime.

Gold stars for everyone contributing to this thread. This is awesome! Let’s see how many of these I can get fixed before Alpha 5…


Now you mention it, in the screenshots I took there is a window frame missing.

1 Like

I have a peculiar bug that happened just today.

I made 2 farmer’s hoe and both of them where placed on top of the carpenter’s workstation. When i tried to get 1 of my workers promoted to farmer, it didn’t register because i think they could not get to it. To remedy this, I moved the carpenter’s workstation and was able to click on the farmer’s hoe to promote someone. The thing was, it kept promoting the person continuously. On the list of people, it kept saying that this worker is being promoted, but it did not actually end the promotion. It became forever stuck in an endless loop of the promotion animation. Sadly i forgot to save the game before closing the application (as this bug happened at the very beginning of the game).

If you guys don’t understand my description of the bug above, please let me know and ill try and explain again.


Did they ever take the scaffolding back down?

Nope… and when the goblins came… well. 2 Villagers not walled up in their own homes was not enough. The rest starved or were stabbed to death through the walls by the goblins.

Needless to say, it was horrifying.

everyone gets what he/she deserves ^^

Not sure what caused this bug.


I have all these lanterns placed and when they turn on (basically at night) the game starts to lag quite a bit. Im pretty sure it has nothing to do with my computer specs (core i7, GT 650M SLI) but i still turned down shadows to no avail.

Another Bug:

He fell off the map. Looks like he really wanted to explore the unknown.

But I know what caused it. I put the house i built right where the map ended. So my worker when there to build it and fell down. Seems like I made such a sill mistake :stuck_out_tongue:


today marks a really bad day, today i was crushed by goblinhords unknown sizes, pictures tell more then any words
they just pooped up maybe 50 blocks away from my city, after a reload the popped at the same position but only 4 a time with something like 5sec in between and were manageable by my 4 footman

1 Like

The lighting engine sucks at the moment, that’s all. Pretty sure @Tom mentioned it was going to get an overhaul eventually, but in the mean time just avoid placing too many light sources.

[quote=“Wynde, post:33, topic:7373”]He fell off the map. Looks like he really wanted to explore the unknown.

But I know what caused it. I put the house i built right where the map ended. So my worker when there to build it and fell down. Seems like I made such a sill mistake :stuck_out_tongue:[/quote]
Not sure what to make of this bug: on the one hand, we shouldn’t be finding any map edges in the full game, but on the other hand what about things like cliffs etc?

Sorry for being so behind on edits, but hopefully that will be all the bugs we need to worry about at the moment :slight_smile:

Thanks all for contributing

1 Like

I’m going to borrow this thread since it’s a multiple list and it’s 134. Short just under 3 minute vid attached.
Showing that the Goblin Horde still exists and what happens now when you die. Things like you get the saw/clothes back.
And that the cowardly weaver will still put things away even when there is a war going on.