Bug List Alpha 4, Release 0.1.0, Build 134

It might be convenient if the scaffolding was not considered as a barrier by the villagers, it would still look realistic (they have big holes) and then villagers would not get stuck inside houses in construction.

A bug screen occured as I was placing an item inside my carpenter’s house and the sun rised at the same time (I had the item selected from the build and design green arrow when I heard the rooster). I don’t know if both events matter for the bug.

Worker ignoring an upgraded outfit

It might be because of my stocking zone settings, but armor is selected though… so I don’t know…

1 Like

Another sunrise bug. This time I still had the stockpile settings window displayed.

liked it so far quite a lot but we definitely need some sort of clean-up-job or the pathfinding got caught in my house

Where is my 2nd door gone??? Did the goblin steal it ? Was it used to build my second house ?

yes, for whatever reason, the outfits didnt get added to any stockpile, which means they wont be picked up/equipped by the units…

1 Like

This happened to me as well. The workers jacked a window from one house to build it into another. But that was in 129

A pathfinding related bug screen

Bug with the placing of tools inside stocking piles, consequence: quest failed

I had a Fur Rug in last position in my crafting queue. I decided to erase it from the queue because I wanted to craft 5 instead of 1. After I dragged the icon on the trash, the Fur Rug icon was still in queue. So I dragged it again on the trash, this time it disappeared from the queue but I got a bug window (upper-right corner of the screen).

1 Like

This time I wanted to build a very big L house. In the design window I draw the L floor, saw that the firepit would be too close to the future house, so I clicked on it directly without leaving the design window, and 2 bug windows appeared.
Also notice the UI bug at the bottom left.

1 Like

Looks like I got a lot of work to add to the list :wink:
I’ll get right on it, thanks all :slight_smile:

My guys have become evil. There was a wood block on the roof, and when loading a save they always build scaffolding on the already-built building, locking on occupants inside. They do get the wood block, though.

No idea what crimes were committed…



Could have potentially doubled up the building… Maybe it tried to build a single wall again, but couldn’t, so they stopped after they made the scaffolding?

No this happened to me too. (In r129). In my case they rebuilt the scaffolding on a building they had previously stolen a window from to use elsewhere… it was an interesting couple hours of playtime.

Gold stars for everyone contributing to this thread. This is awesome! Let’s see how many of these I can get fixed before Alpha 5…


Now you mention it, in the screenshots I took there is a window frame missing.

1 Like

I have a peculiar bug that happened just today.

I made 2 farmer’s hoe and both of them where placed on top of the carpenter’s workstation. When i tried to get 1 of my workers promoted to farmer, it didn’t register because i think they could not get to it. To remedy this, I moved the carpenter’s workstation and was able to click on the farmer’s hoe to promote someone. The thing was, it kept promoting the person continuously. On the list of people, it kept saying that this worker is being promoted, but it did not actually end the promotion. It became forever stuck in an endless loop of the promotion animation. Sadly i forgot to save the game before closing the application (as this bug happened at the very beginning of the game).

If you guys don’t understand my description of the bug above, please let me know and ill try and explain again.


Did they ever take the scaffolding back down?