[b1658] [r166]Weaver not placing their station "unclaimed"

Summary: when trying to place the weaver’s table it would not assign the table to the weaver you were placing it from.
Steps to repro:
1.create a weaver class
2.attempt to place the weaver’s station
3. does not get built but instead left “unclaimed”
Expected results: weaver builds there station
Actual results: a bunch of planned out weaver stations but no one builds them and weaver does not claim
Notes: I tested this by clicking the place station multiple times, so heres the pics of the results/tests
(can you guess which one is the first…)

1 Like

Tried saving and reloading? Wondering if this is a pathfinding bug, because I’ve not seen this in my 1658 games :confused: .

ya i saved and reloaded, and even exited my game. It saves to the world file i think, probably just a bugged out weaver on my part.

1 Like

This bug is still present in alpha 6 full release when I tried to place down a weaver station. I found that it works with some worlds but not with others, maybe something corrupts the world? I don’t know so here is the picture in alpha 6 release edit I tried demoting and switching the weaver class to another person and I got the same effect in the same world

1 Like

After promoting a weaver i made him place his Spinwheel but it would’nt place and no one would do anything about it so i tried a couple other times. I also tried placing outside to check if it was underground only but it seems to be everywhere.



I have yet to find this an issue in the latest unstable build, so Im going to be the guy that asks:

  1. Have you got wood and silk/cotton thing from the plants available either in a stockpile or sitting nearby?

  2. Did you notice anything go “wrong” before this happened, like the error text boxes appearing or a villager not doing the right thing? (an example would be the footman had stopped patrolling and was collecting goods to the stockpile)

1 Like

Besides point 1 that @Tonky mentioned, are you sure that the weaver could access the place where you were placing the workshop?

@Tonky yes i did, also a couple of my hearthlings stopped builing fences even when there were loads in the stockpile, they fences just stayed in the ghost planning mode and my villagers would’nt bring the actual fences over and build it.

@Relyss yes he could, other people including him would walk through there to do other stuff.

This issue is still ongoing in ALPHA 9 R223. I loaded a saved game, and the Weaver workshop was “unclaimed” and no longer usable.

I tried to get the weaver to place another. It did so, however, it refuses to use it. Essentially the game is broken now, because it’s impossible to play a successful game without the weaver working.

it worked well for a while until it didn’t. I have the save game if it can help. I have screenshot as well

1 Like

Seen this same effect for the blacksmith workshop in R223 (35:25). The blacksmith instead went on to do other activities, such as helping to build houses (37:35). See attached video at indicated times.

Same Issue for Blacksmith Alpha 10? Unsre what build