Assertion Failed and Engine Error on Multiplayer


#1

Summary:
I join a friend’s game through Steam and the game lags as if its stopping every 2 seconds
And would randomly do an assertion failed error and engine error that would crash the game or make other problems.
Steps to reproduce:

  1. Connect to friend
  2. Lag randomly through out the entire game
  3. Errors appear sooner or later

Attachments:
image

Version Number and Mods in use:
1.1.0 x64 Release 947
ACE
Northern Alliance
Rayya’s Children
Cettect: Colorful Stones Set
Farmer and Cook House
Raillwood - Basic Template Pack
Riallwood - High Template Pack
Riallwood - Wall and Defences
Skuldos - Basic Template pack
TMD - Excavation
TMD - Tier I Buildings
TMD - Tier II Buildings
TMD - Tier III Buildings
Town Center “Little Palace”
Vasedro - Basic Template Pack
Vasedro - High Template Pack
Vasedro - Walls and Defences

System Information:
i7 - 8700k
16GB DDR4 RAM
GTX 1050 Ti
Windows 10 Pro 64-bit


#2

Here’s the Engine Error I just got after joining the game

release-947 (x64)[M]

radiant/modules/entities.lua:314: attempt to index local ‘entity’ (a nil value)

stack traceback: [C]: ? radiant/modules/entities.lua:314: in function ‘get_player_id’ …hearth/services/server/building/building_service.lua:384: in function <…hearth/services/server/building/building_service.lua:382>


#3

Something to add is that pausing the game and then hitting play after 5 seconds sometimes fixes the lagging , but not all the time.
I think when the gap in delay gets too much is when my game crashes. But that’s just my theory since sometimes this error pops up 2 seconds after joining back in the game.