Alpha 18 assertion failed upon exiting


Steps to reproduce:

  1. play
  2. hit “esc.”
  3. click on “exit game”

Expected Results:
the game closes

Actual Results:
Assertion failed popup : waiting_posts_.empty()(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\lib\analytics\analytics_logger.cpp:121

Clicked on OK and the game eventually has closed


Version Number and Mods in use:
Alpha 18

System Information:

Thanks! I believe I have a fix for the next patch (after Develop-3092).

The pop-up is no more appearing with latest patch (to me).

1 Like

I had been playing for maybe 10 minutes when I decided I wasn’t feeling it today. I saved my game, and then tried to use the exit game button. Nothing happen. I tried again. The same. So I tried to quit to the main menu. It then took me to the screen with the golem in the background, where it then stuck. I had to Alt-Tab out, and when I did, I had this windows error message.

2016-08-16 15:49:18.315352 | server | 0 | app | Assertion Failed: waiting_posts_.empty()(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\lib\analytics\analytics_logger.cpp:121)

Which was also in the log.