Alpha 15: "no enemy location for mission"

Summary: Upon starting to build a house the error message pasted under “Notes” popped up. Seems unrelated to building, though.

Steps to reproduce:

  1. ?
  2. ?
  3. ?

Expected Results: No error.

Actual Results: Error.

Notes:
develop-2860 (x64)co-routine failed: …/server/game_master/controllers/missions/mission.lua:110: assertion failed: no enemy location for mission { offset = { y = 0, x = 0, z = 0 }, role = “pillage”, sighted_bulletin = { title = “i18n(stonehearth:data.gm.campaigns.ambient_threats.random_raid.mission.sighted_bulletin.title)” }, ctx_entity_registration_path = “golem_family_raid_4”, pillage_radius = { min = 0, max = 50 }, members = { little_stone_golems = { from_population = { min = 1, role = “little_stone_golem”, max = 2, range = 20, location = { z = 0, x = 0 } }, loot_drops = { entries = { default = { items = { stone = { uri = “stonehearth:resources:stone:hunk_of_stone” } } } } } }, stone_golems = { scale = 0.25, from_population = { location = { z = 0, x = 0 }, role = “stone_golem”, max = 1, min = 1 }, attributes = { max_health = 250 }, loot_drops = { entries = { default = { items = { stone = { uri = “stonehearth:resources:stone:hunk_of_stone”, weight = 10 }, ore4 = { uri = “stonehearth:resources:tin:ore”, weight = 3 }, ore5 = { uri = “stonehearth:resources:copper:ore”, weight = 3 }, ore3 = { uri = “stonehearth:resources:gold:ore”, weight = 1 }, ore1 = { uri = “stonehearth:resources:iron:ore”, weight = 2 }, ore2 = { uri = “stonehearth:resources:silver:ore”, weight = 2 }, lump_of_coal = { uri = “stonehearth:resources:coal:lump_of_coal”, weight = 3 } } } } } } }, npc_player_id = “forest” }stack traceback:
[C]: in function 'error’
radiant/modules/common.lua:431: in function ‘assert’
…/server/game_master/controllers/missions/mission.lua:110: in function ‘_create_party’
…/server/game_master/controllers/missions/mission.lua:39: in function ‘start’
…game_master/controllers/missions/pillage_mission.lua:20: in function ‘start’
…/controllers/encounters/create_mission_encounter.lua:63: in function '?'
radiant/modules/common.lua:395: in function ‘invoke’
…er/controllers/util/choose_location_outside_town.lua:340: in function ‘_invoke_callback’
…er/controllers/util/choose_location_outside_town.lua:171: in function ‘_try_finding_location’
…er/controllers/util/choose_location_outside_town.lua:144: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

Attachments: Here’s the save file.

Version Number and Mods in use: develop-2860 (x64); Archipelago Biome mod (not used with that certain save). Save started in Alpha 14.

System Information: Core i5 3470, GTX 970, 8 GB RAM, Win 7 64-Bit

Thanks for the report! I’m putting in a fix for the next unstable build. Let me know if you run into this again afterwards.
-Linda

4 Likes