ACE - Authorized Community Expansion Project

They keep working in the mod?

1 Like
1 Like

I have this error pop up too :frowning:

1 Like

Hey folks. I suppose I’ve found a bug. What can I do about it?

Description:

  1. When looking through town inventory I find 2 wild plants (sweet potatoes) listed as mine, 1 of them as ‘undeployed’.
  2. Search through placeable objects, though, shows NO seeds or plants to deploy.
  3. Okay, I click on the plant in town inventory and it shows a deployed plant. I click again (usually the game switches to the next item) - and it list an undeployed plant as selected (bottom left, has only ‘place item’ button, no ‘move’ and ‘undeploy’ buttons) but does NOT scroll map to its location.
  4. I press ‘place item’ on the selected plant, and my hearthlings… pick up an already deployed plant and move it to the new place.

Looks like the game somehow lists the SAME plant twice, once as deployed and once as undeployed.

I’m not sure if it is about ACE or vanilla SH (I started playing again just now).

1 Like

Also, it looks like currently charcoal does is not recognized properly as coal filter-wise. Hearthlings don’t move charcoal from stockpiles that have ‘coal’ switched off to other stockpiles.

Edit: looks like charcoal is considered ‘coal’ and ‘other fuel’ at the same time. To ensure a certain stockpile doesn’t hold these, tick both off.
Still not sure if it is correct.

Edit 2: same with plants and healing herbs. Looks like storage filters don’t work well with multiple overlapping subcategories.

1 Like

Im having a hard time trying to get my game to run with the ACE mod. I’ve fiddled with it for several days. Base game that’s 100% vanilla works great. As soon as I add the ACE folder to the ‘mods’ folder, the game doesn’t start up. It stays on a black screen, doesn’t load anything, not even the music. I have the game on steam and Its very disappointing that I cannot play such an amazing mod. I love this game and I’m fairly new to the community. I would give all my support and love to this game. So I hope someone sees this post and can help figure this out. :confounded:

Are you trying to use the stable version of ACE from the Steam Workshop, or the unstable version that has to be installed in the Stonehearth/mods folder?

I’ve tried both… both doesn’t seem to work…

usual answer first
uninstall, manually remove leftover files, reinstall

try the stable version first, install it using steam
check if ace is the only active mod in the middle collumn

Just wait more, ace is a big mod and will make your game way more slow. After waiting a longer time in the blackscreen, press f5, this will refresh the screen and reload the ui, which could be unresponsive and is usually what happens in these case

2 Likes

Bruno you are awesome! I’m disappointed that I didn’t ask sooner! Im gonna try adding my favorite mods one by one and test the game… ohhhh i’m excited to finally play this mod! Thank you and everyone’s suggestions!

2 Likes

Good afternoon everyone.
Guys, how about a “Leisure time” update ? Is it feasible?

I mean, including actions/animations like two hearthlings dating while sitting on a banch looking at the moon, festivities (imagine a Northern Alliance Town rejoycing spring has finally come), a hearthling lazily spending time near a lake with friends, or reading a book inside a library, or even taking a refreshing bath after a long day?

I think this would add a lot to gameplay experience. Of course, this is not meant to be integrated into everyday activities, but rather be an end game reward, an achievement, a motivation for striving for more productive/eficient hearthlings. The idea is making this feature work like the training dummy right now: in an on/off toggle basis. At Town tier 1 you can only give rest for one afternoon before auto toggling off, at Town tier 2 for every 7th day afternoon, and at tier 3 for every day afternoons - as if a Town of Dreams.

I am willing to work on such na update, if it is viable, and of course possible for someone which only studied Fortran and knows a bit about Matlab.

2 Likes

i like that idea! it would make it seem more alive.

@Slashkoln sounds great

@DaniAngione Wulfkin? is that you? Haven & Hearth?

1 Like

Yes, that is me

wow that is kind of crazy. hope everything is going well with you

1 Like

LOL @DaniAngione if you were Wulfkin it means we’ve met in game, I still have you as kin xD

1 Like

Seriously? :joy:
You mean in World 7, right? Before the new version
That’s funny :joy:

Hi to all!
I have an issue with crops - empty list for all fields and error on start
ACE 9.5, works fine on 9.4.3
All fractions, all maps

Stacktrace is awwww…
2020-05-17 10:50:25.764640 | server | 1 | lua.code | generating traceback…
2020-05-17 10:50:25.765617 | server | 0 | lua.code | – Script Error (lua) Begin ------
2020-05-17 10:50:25.765617 | server | 0 | lua.code | …onehearth_ace/monkey_patches/ace_farming_service.lua:74: attempt to index local ‘catalog_data’ (a nil value)
2020-05-17 10:50:25.765617 | server | 0 | lua.code | stack traceback:
2020-05-17 10:50:25.765617 | server | 0 | lua.code | [C]: ?
2020-05-17 10:50:25.765617 | server | 0 | lua.code | …onehearth_ace/monkey_patches/ace_farming_service.lua:74: in function ‘get_crop_details’
2020-05-17 10:50:25.765617 | server | 0 | lua.code | …onehearth_ace/monkey_patches/ace_farming_service.lua:54: in function <…onehearth_ace/monkey_patches/ace_farming_service.lua:37>
2020-05-17 10:50:25.765617 | server | 0 | lua.code | (tail call): ?
2020-05-17 10:50:25.765617 | server | 0 | lua.code | stonehearth/call_handlers/farming_call_handler.lua:63: in function <stonehearth/call_handlers/farming_call_handler.lua:62>
2020-05-17 10:50:25.765617 | server | 0 | lua.code | – Lua Error End ----------------

1 Like