[A16/A17] The buildings my hearthlings will not build (round 2!)

me again. At this time, the settlers not completed two parts of the building


A similar missing piece on the other side of the house

farm house full.zip (21.6 KB)

1 Like

Hi, I worked on a two-piece building in Alpha 17, build 3023. The hearthlings do not start to build the building, although the materials are in stock. I get this error message when I load the savegame:

develop-3023 (x64)…/fixture_fabricator/fixture_fabricator_component.lua:171: attempt to index local ‘building’ (a nil value)stack traceback:
[C]: ?
…/fixture_fabricator/fixture_fabricator_component.lua:171: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:42: in function <…/fixture_fabricator/fixture_fabricator_component.lua:40>
develop-3023 (x64)c++ exception: lua runtime errorstack traceback:

I uploaded the template.

Best,
Benmy new building template.zip (51.1 KB)

hey there @thyariol, welcome to the discourse :smile:

sorry about that, i just bumped you up to TL1, so you should be able to upload it now :slight_smile:

Thank you! I added the template to my previous posting.

Best,
Ben

Though much improved, I was able to replicate a portion of this problem in A17 R566, using just the pre-baked templates:

The back wall of the under-construction house never gets further than what’s pictured. The rest of the walls except the roof get built fine and then the build stalls until I place a single ladder on the inside of the second story. Once they advance the build a level or two, I need to raise the ladder height up and repeat the process a couple times until the build clears the roof of the other building. From there the AI takes over again and finishes the build fine.

Much MUCH less helping required this time, though I did notice them build a second layer of scaffolding in order to start working on the roof. But, they tore it all down cleanly, so it’s definitely better. Nice job, @not_owen_wilson.

I am almost starting to miss the old building, even if they had a lot of scaffolding… At least then I know they will build free standing layer by layer.


Notice a problem in the way they decided to build this free standing building…
Soon after I got 3 errors:



And this is how much they got finished:

Reminds me of the way they built my smith against the cliff, except that one if the cliff wasn’t there they would finish… Maybe… starting to wonder since they decided not to even finish the one wall of the main structure.

Slab roof, and designed in a way that I probably could get to build in A15. Of course I haven’t tried, but my theory is sound, since in A15 it would go until the entire foundation was complete. All slabs at foundation level are foundation floor tool. This would usually work in A15 to at least get them to build things in order. Layer by layer as I put it in the beginning.

they just didn’t get around to building up the scaffolding in time for that specific wall for some reason.

stonewood mason workhouse f.zip (24.7 KB)
stonehearth.log (2.7 MB)
I did see if they could at least take the scaffolding down if I ib the rest. They didn’t, there was quite a bit left.

Also note throughout the process of building the built unneeded scaffolding right under something that has already been built; ie a portion of the roof over the open area of the build within the section that was not walled in by auto-wall tool.

Don’t think a save is needed for this one, but I have one if you need it. Although it will be when they stopped building due to their own mistake. ><

What can you do when hearthlings seem to build after hitting the bar per say. Well hopefully I’ll be able to build again like I was able to before. At least the old system it was easy to tell when they will build and when not. This one… At the moment is a bit sporadic/random like seen in the pic.

A17 566

Building
This is how the building is suppose to look i instant built it because they got stuck

This is where they got stuck everytime where ever i decided to put it

I removed the slab over the entrance that was attatched to the wall as you can see on the picture above and they built further than before and maybe will even finish.
Hopefully this might help devs to do something about this building issue that the slab against the wall seems to prevent them to continue since they did continue once i decided to try remove this slab sloped roof over the entrance

2 Likes

Looks like similar to what happened to mine… Order of operation. that is if seeing that right and they didn’t get to the wall that is on lower floor… but got to the awning bit first… That basically blocks the way. Confused why they decided to build in that order; which also somewhat happened in mine… Basically build order of pieces they decide to do.

This new system is going to take a bit of time to figure out… :stuck_out_tongue:

A post was merged into an existing topic: Hearthlings Don’t Take Down Scaffolding

A post was merged into an existing topic: Hearthlings Don’t Take Down Scaffolding

I apologize if I use the topic too often, but I just know how to break the game =)

Now the crown of my creations - not just break the template itself on installation (wall disappear), but also i lost the ability to edit ALL structures in game. And autosave have no sreenshot in menu =/

windmill.zip (16.9 KB)


2 Likes

Hey everyone, we have a new building-focused release for you, up on Steam Unstable. Please give it a go and let us know if your buildings are building yet. :wink: This one is for all of you. :slight_smile:

2 Likes

In regard of this posting.

With the new update (steam latest) the hearthlings finally start building. Of course, I have to check if they will finish the building, but now there’s progress. Thank you very much for your effort, devs.

2 Likes

http://discourse.stonehearth.net/t/a16-a17-the-buildings-my-hearthlings-will-not-build-round-2/22200/57?u=genboom

It does build now! :grinning: however…

I think this build is a good example of what the AI is still doing wrong. One (make that two) of my builders still got stuck on the stair rails during building. The hearthlings do not prioritize building the floor and stairs first - making the second story take much much longer than it should. This building alone took me about a week to complete and this has only the basic furniture and decorations to get started in the game. This is not something you could build at the start of the game even though you need 10 rooms fairly quickly. The build speed of something like this still needs to be doubled at the very least to be even considered worth the time invested when I could dedicate my hearthlings to improve my wealth or craft things much easier and faster. So so so much time is wasted on scaffolding its frustrating to watch.

Scaffolding should not be built on both sides of walls, ever - interior walls are terrible. Anything you have overhanging is also really really bad because they won’t build the floor and walk on it, they will build a ladder that goes into space first and use it instead. Thats another thing, ladders are being over-placed I don’t need 20 ladders to reach the second floor of the building if they just built the stupid floor in the first place. Gahhh :tired_face:

1 Like

Paging @not_owen_wilson who has thought 100x more about dependencies than I have. :wink:

Still, I’m glad it builds now! Let’s go after one epic problem at a time, shall well? :wink:

5 Likes

silly 4 story design.zip (13.6 KB)
0000000000000.zip (5.2 MB)

I would like you guys to try to tackle something like this, where I dig out the foundation for a building that I want to have a basement. The one on the right (based on the ground) will build. but the one dug into the ground on the left does not. Also two hearthlings get trapped within the empty stairs and will starve to death because I have no way of getting them out.

Currently the only fix for this build is to dig out the hole in the ground 2 more on each side and put a ladder down the hole for your hearthlings to access it. It would also probably be easier to not include the stairs as part of the basement and just leave them as dirt blocks. Still I think something like this should be possible without having to dig around your building for ladder access.






1 Like

I posted this in the newest unstable thread but it belongs here:
empty_bulwark.zip (27.9 KB)

It has a -2 height crenellation on top that won’t build, but -1 height does.

so started a new game on release 572 and after a long time of designing I got the following
release-572 (x64)[M]…onehearth/components/building/building_component.lua:204: attempt to index local ‘entry’ (a nil value)stack traceback:
radiant/modules/common.lua:237: in function ‘report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
…onehearth/components/building/building_component.lua:204: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:179: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:84: in function ‘set_active’
…ruction_progress/construction_progress_component.lua:81: in function ‘set_active’
…onehearth/components/building/building_component.lua:406: in function ‘cb’
…onehearth/components/building/building_component.lua:400: in function ‘_call_all_children’
…onehearth/components/building/building_component.lua:396: in function ‘_call_all_children’
…onehearth/components/building/building_component.lua:396: in function ‘_call_all_children’

radiant/controllers/time_tracker_controller.lua:82: in function ‘set_now’
radiant/controllers/time_tracker_controller.lua:103: in function ‘increment_now’
radiant/modules/timer.lua:13: in function ‘instance’
radiant/modules/events.lua:227: in function <radiant/modules/events.lua:221>
[C]: in function ‘xpcall’
radiant/modules/common.lua:257: in function ‘xpcall’
radiant/modules/events.lua:221: in function ‘trigger’
radiant/modules/events.lua:290: in function ‘_trigger_gameloop’
radiant/modules/events.lua:338: in function ‘_update’
radiant/server.lua:62: in function <radiant/server.lua:58>

japanese castle.zip (42.8 KB)

For some reason after the error all my roads in this build are gone :frowning: After saving and reloading i get extra errors.
release-572 (x64)[M]…onehearth/components/building/building_component.lua:204: attempt to index local ‘entry’ (a nil value)stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:204: in function ‘get_dependencies’
…/fixture_fabricator/fixture_fabricator_component.lua:179: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:42: in function <…/fixture_fabricator/fixture_fabricator_component.lua:40>
release-572 (x64)[M]c++ exception: lua runtime errorstack traceback:

2 Likes

some added info, placed it again in a new map, placed an extra layer of slabs below the road blocks and that seems to stop the error. Still he is having issues with this build. Also had a villager die because of scaffolting removal :slight_smile:

new save of the same template
japanese castle2.zip (38.0 KB)

After save attempt it crashed :frowning:
crash.dmp (174.2 KB)
stonehearth.log (4.5 MB)

2 Likes

craft stall and display 2.zip (4.4 KB)

Everything goes fine until the scaffolding removal process.

Steam Latest build:572
No crash.
Hearthling respond fine after and continue normal jobs.

Update: Can be taken off the list as of Build 582. The job get’s completed.

1 Like