[A16/A17] The buildings my hearthlings will not build (round 2!)

They stopped pretty early with building this in A17 Dev 3010 (m)

Settlement Decor
Spiros Window
None of the mods are used on this house

How far they got with building this

How it should look when done

Building Template
banto a17 3010 not built fully.zip (21.4 KB)

Started a fresh game today with the new A17 dev-3013 release.

So I’ve been trying out some of the templates uploaded to stonehearthbuilds.esy.es and have been getting a lot of scaffolding teardown issue, both on this release and earlier A17 releases.

So today I started building a wall using these templates:

And it seems to go okay for a while and then the hearthlings will switch to idle, most times when this happens I’ll just do a hard save and reload and they will start building again, at other times it will throw this error

develop-3013 (x64)
...omponents/scaffolding/scaffolding_project_volume.lua:185: attempt to call method 'set_teardown' (a nil value)
stack traceback:
	[C]: in function 'set_teardown'
	...omponents/scaffolding/scaffolding_project_volume.lua:185: in function '_on_project_changed'
	...omponents/scaffolding/scaffolding_project_volume.lua:90: in function <...omponents/scaffolding/scaffolding_project_volume.lua:77>

develop-3013 (x64)
c++ exception: lua runtime error
stack traceback:

So there seems to be an issue with removing scaffolding on some more “complex” structures.

If scaffolding is removed manually with the console ‘destroy’ command this and potentially other errors seems to pop up regularly when saving and reloading.

1 Like

This thread is the closest, as it does relating to building in general.

The problem is within the pics. The second one is how far they had gotten with the build, and just stopped.

What it is suppose to look like.

Yes this will most likely build when there is nothing around it, so that much is clear. My problem is I like building things up against mountains, cliffs, and the like. Building with the terrain, so yes there will be things away from wall from time to time, but generally more often than not I will want to build next to a cliffside like this.

In A14-A15, namely the latter portion; if built a certain way, it will build. Now though thing will build no matter the way, with some exceptions. The way A15 did it was layer by layer most of the time. The changes are very apparent, since they don’t build layer by layer now; evidence in the pic. I mean they didn’t even finish the first floor, before starting the second. They use to in the very least waited till the first floor was finished.

The actually problem is that the quadrent that it is in happens to be a very thin line, and that portion just got ignored most of the project. I did however try and help them along with a ladder, but I was too late and they built the second story floor. ><

Maybe one of these days we will be able to build right up against the cliff like this without having to dig the cliff out to accommodate scaffolding. At least with the RC buildings. Oh by the way The rooffing is obviously custom slab roof.

stonewood smithy 2s f cliff.zip (29.5 KB)
stonehearth.log (792.2 KB)

Well at least A17 has improved in what can be built, that does make me happy. I’ll just keep trying to point out and break building… :stuck_out_tongue: In my own way of course, since I generally don’t build big things; they just end up bigger modular pieced together things… as a whole. :slight_smile:


dev 3013 x64

gets halfway done

a problem with it I didn’t notice is it separated the far right balcony pillar “leg” as a different building or something, very odd it didn’t even show up in the image, but it was constructed the same time as the rest of the building. I think it did this because it has a floor block that is separate from the rest of the build, and didn’t connect to the balcony because of this.

hotel layout.zip (14.3 KB)


extravagant keep.zip (104.0 KB)

So, I have this keep that won’t build. At all. Hearthlings don’t even acknowledge that it’s there. This is build 3013 BTW. When I first built it, for some reason as I was building on the editor randomly decided to break the build into two separate buildings. There seemed to be no rhyme or reason as to where the break occured. It took parts from multiple levels and assigned them to two separate buildings. So I went back to an older save where everything was still in one piece, and managed to save what I had into a template. Now when I try to place said template, a chunk is always missing out of the front wall, and of course the Hearthlings refuse to build any of it. It’s probably just too big, but I’d love to see it get built.

This is the saved template:

This is where it was originally designed before it was split up into two unbuildable chunks:


I’ve got one.

3019 x64

Link to the template: Dwarf Door

It’s intended to be the entryway for an underground city. Here’s what it looks like:

It’s intended to be flush with the cliff-face, with a 4x4 tunnel behind the door.

When it’s built out in the open (with no cliff), they finish building it but leave some of the scaffolding. When it’s built against the cliff, they don’t finish it at all.


Here another Build they wont build right
@yshan here is another build for him

For some reason they dont finish floor and also cont to build tops


1 Like

to bad you have building issue, because i like the build :slight_smile:

1 Like

I posted this for a completely different bug (which wasn’t a bug) before realizing my hearthlings were having trouble building it.

Game’s End Eatery.zip (46.9 KB)

They don’t seem to like the inverted L-shaped chest shelves. The ladder on the left is actually mine, but it unfortunately didn’t help them any. Later I got discovered that you can attach ladders to ghost furniture once the villagers have entered the laying down furniture stage, so I added a ladder to the side and lower front. Lo and behold:

Shelves. I had to add ladders to the front so they can (hopefully) put the upper shelf boxes in, but I was going to have to do that anyway so they could reach said boxes when the eatery was finished, so I’m not terribly bothered. A little annoying that I have to do this after the furniture starts getting put in rather than during the initial design phase, but meh.

They seem like they’re going to be happy to finish it now, although the game’s grinding to a halt and I need to let my computer cool down.

The one out in the open is finished, the hearthlings can’t take the scaffolding down because they can’t reach it, build a 1 block high ladder at the base of each of the bits of scaffolding and they’ll take it down.

The other is stuck because they want to place the blocks in between the cliff and the front lighter grey panel but can’t get there building a ladder so they can walk along the top of the grey front bit might fix this.

I understand how I could work around it, if I choose to. This thread is for sharing builds that the Hearthlings won’t finish.

me again. At this time, the settlers not completed two parts of the building

A similar missing piece on the other side of the house

farm house full.zip (21.6 KB)

1 Like

Hi, I worked on a two-piece building in Alpha 17, build 3023. The hearthlings do not start to build the building, although the materials are in stock. I get this error message when I load the savegame:

develop-3023 (x64)…/fixture_fabricator/fixture_fabricator_component.lua:171: attempt to index local ‘building’ (a nil value)stack traceback:
[C]: ?
…/fixture_fabricator/fixture_fabricator_component.lua:171: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:42: in function <…/fixture_fabricator/fixture_fabricator_component.lua:40>
develop-3023 (x64)c++ exception: lua runtime errorstack traceback:

I uploaded the template.

Benmy new building template.zip (51.1 KB)

hey there @thyariol, welcome to the discourse :smile:

sorry about that, i just bumped you up to TL1, so you should be able to upload it now :slight_smile:

Thank you! I added the template to my previous posting.


Though much improved, I was able to replicate a portion of this problem in A17 R566, using just the pre-baked templates:

The back wall of the under-construction house never gets further than what’s pictured. The rest of the walls except the roof get built fine and then the build stalls until I place a single ladder on the inside of the second story. Once they advance the build a level or two, I need to raise the ladder height up and repeat the process a couple times until the build clears the roof of the other building. From there the AI takes over again and finishes the build fine.

Much MUCH less helping required this time, though I did notice them build a second layer of scaffolding in order to start working on the roof. But, they tore it all down cleanly, so it’s definitely better. Nice job, @not_owen_wilson.

I am almost starting to miss the old building, even if they had a lot of scaffolding… At least then I know they will build free standing layer by layer.

Notice a problem in the way they decided to build this free standing building…
Soon after I got 3 errors:

And this is how much they got finished:

Reminds me of the way they built my smith against the cliff, except that one if the cliff wasn’t there they would finish… Maybe… starting to wonder since they decided not to even finish the one wall of the main structure.

Slab roof, and designed in a way that I probably could get to build in A15. Of course I haven’t tried, but my theory is sound, since in A15 it would go until the entire foundation was complete. All slabs at foundation level are foundation floor tool. This would usually work in A15 to at least get them to build things in order. Layer by layer as I put it in the beginning.

they just didn’t get around to building up the scaffolding in time for that specific wall for some reason.

stonewood mason workhouse f.zip (24.7 KB)
stonehearth.log (2.7 MB)
I did see if they could at least take the scaffolding down if I ib the rest. They didn’t, there was quite a bit left.

Also note throughout the process of building the built unneeded scaffolding right under something that has already been built; ie a portion of the roof over the open area of the build within the section that was not walled in by auto-wall tool.

Don’t think a save is needed for this one, but I have one if you need it. Although it will be when they stopped building due to their own mistake. ><

What can you do when hearthlings seem to build after hitting the bar per say. Well hopefully I’ll be able to build again like I was able to before. At least the old system it was easy to tell when they will build and when not. This one… At the moment is a bit sporadic/random like seen in the pic.

A17 566

This is how the building is suppose to look i instant built it because they got stuck

This is where they got stuck everytime where ever i decided to put it

I removed the slab over the entrance that was attatched to the wall as you can see on the picture above and they built further than before and maybe will even finish.
Hopefully this might help devs to do something about this building issue that the slab against the wall seems to prevent them to continue since they did continue once i decided to try remove this slab sloped roof over the entrance


Looks like similar to what happened to mine… Order of operation. that is if seeing that right and they didn’t get to the wall that is on lower floor… but got to the awning bit first… That basically blocks the way. Confused why they decided to build in that order; which also somewhat happened in mine… Basically build order of pieces they decide to do.

This new system is going to take a bit of time to figure out… :stuck_out_tongue:

A post was merged into an existing topic: Hearthlings Don’t Take Down Scaffolding