[A16/A17] The buildings my hearthlings will not build (round 2!)

sorry about that, i’ve bumped you up to TL1 so you should be able to upload stuff now :slight_smile:

Still won’t let me upload the zipped file.

This gate house builds fine but lots of scaffolding remains inside and out.

https://www.dropbox.com/s/pq1o3wz9qmgqyam/gate%20house.json?dl=0

townhouse.zip (5.8 KB)

previously worked in A16; no longer builds

To see that my thread has a kid now :cry:
I am soooo proud

2 Likes

Ok I have made the most complex that I have ever built so far. Makes my RC buildings look quite simple, and in theory you would be right.

With this one, it is not that it didn’t build. I am posting due to the scaffolding, and an error I got while building; which I am not entirely sure if was the cause.


stonehearth.log (665.8 KB)

What you see in the pic is how far I got before save & reloading, which did not help. What did get them to build was pause & resume building. Had to do that a few times before they finished, and due to the position I had to make a ladder for the last window.

Another problem I had was with carpenter que. I had blank sign on 1= (maintain). I have a large que, but when I put to have the 2 signs just to craft 1 of each, the carpenter got stuck on those signs. Trying to do those even though the blank sign requirement was further up the que than them. So the blank one did not get made until I actually removed and let the carpenter make the maintain part. It was like the craft once was taking priority over the maintain regardless of the position in que.

So this building at the moment sits with the last of its’ scaffolding. I noticed like the other one I have posted here before it was building oddly. Although building in quadrants it would literally build the closest and only that quadrant up to the wall; what you see in the pic, which was 3 quadrants or segments. At least I got them to build it, but can’t say much on the scaffolding take-down which is the primary reason I am posting beyond the error I got.

Note: This building I only used the wall & slab tool. Yes my first custom roof. :slight_smile:

Hearthlings won`t make the walls or the roof, they only make the foundations, the base and crenelation slabs and the three slab columns.

Hearthlings will make most walls, foundation, slabs and the third floor, but won`t make the facade walls nor the second floor and will leave the roof half done.

2 Likes

They stopped pretty early with building this in A17 Dev 3010 (m)

Mods
Endpieces
Settlement Decor
Spiros Window
Doorways
None of the mods are used on this house

How far they got with building this

How it should look when done

Building Template
banto a17 3010 not built fully.zip (21.4 KB)

Started a fresh game today with the new A17 dev-3013 release.

So I’ve been trying out some of the templates uploaded to stonehearthbuilds.esy.es and have been getting a lot of scaffolding teardown issue, both on this release and earlier A17 releases.

So today I started building a wall using these templates:
http://stonehearthbuilds.esy.es/builds/build94.zip
http://stonehearthbuilds.esy.es/builds/build96.zip

And it seems to go okay for a while and then the hearthlings will switch to idle, most times when this happens I’ll just do a hard save and reload and they will start building again, at other times it will throw this error

develop-3013 (x64)
...omponents/scaffolding/scaffolding_project_volume.lua:185: attempt to call method 'set_teardown' (a nil value)
stack traceback:
	[C]: in function 'set_teardown'
	...omponents/scaffolding/scaffolding_project_volume.lua:185: in function '_on_project_changed'
	...omponents/scaffolding/scaffolding_project_volume.lua:90: in function <...omponents/scaffolding/scaffolding_project_volume.lua:77>

develop-3013 (x64)
c++ exception: lua runtime error
stack traceback:

So there seems to be an issue with removing scaffolding on some more “complex” structures.

EDIT:
If scaffolding is removed manually with the console ‘destroy’ command this and potentially other errors seems to pop up regularly when saving and reloading.

1 Like

This thread is the closest, as it does relating to building in general.



The problem is within the pics. The second one is how far they had gotten with the build, and just stopped.


What it is suppose to look like.

Yes this will most likely build when there is nothing around it, so that much is clear. My problem is I like building things up against mountains, cliffs, and the like. Building with the terrain, so yes there will be things away from wall from time to time, but generally more often than not I will want to build next to a cliffside like this.

In A14-A15, namely the latter portion; if built a certain way, it will build. Now though thing will build no matter the way, with some exceptions. The way A15 did it was layer by layer most of the time. The changes are very apparent, since they don’t build layer by layer now; evidence in the pic. I mean they didn’t even finish the first floor, before starting the second. They use to in the very least waited till the first floor was finished.

The actually problem is that the quadrent that it is in happens to be a very thin line, and that portion just got ignored most of the project. I did however try and help them along with a ladder, but I was too late and they built the second story floor. ><

Maybe one of these days we will be able to build right up against the cliff like this without having to dig the cliff out to accommodate scaffolding. At least with the RC buildings. Oh by the way The rooffing is obviously custom slab roof.

stonewood smithy 2s f cliff.zip (29.5 KB)
stonehearth.log (792.2 KB)

Well at least A17 has improved in what can be built, that does make me happy. I’ll just keep trying to point out and break building… :stuck_out_tongue: In my own way of course, since I generally don’t build big things; they just end up bigger modular pieced together things… as a whole. :slight_smile:

2 Likes

dev 3013 x64

gets halfway done

edit:
a problem with it I didn’t notice is it separated the far right balcony pillar “leg” as a different building or something, very odd it didn’t even show up in the image, but it was constructed the same time as the rest of the building. I think it did this because it has a floor block that is separate from the rest of the build, and didn’t connect to the balcony because of this.

http://i.imgur.com/51WeisO.png
hotel layout.zip (14.3 KB)

3 Likes

extravagant keep.zip (104.0 KB)

So, I have this keep that won’t build. At all. Hearthlings don’t even acknowledge that it’s there. This is build 3013 BTW. When I first built it, for some reason as I was building on the editor randomly decided to break the build into two separate buildings. There seemed to be no rhyme or reason as to where the break occured. It took parts from multiple levels and assigned them to two separate buildings. So I went back to an older save where everything was still in one piece, and managed to save what I had into a template. Now when I try to place said template, a chunk is always missing out of the front wall, and of course the Hearthlings refuse to build any of it. It’s probably just too big, but I’d love to see it get built.

This is the saved template:

This is where it was originally designed before it was split up into two unbuildable chunks:

3 Likes

I’ve got one.

3019 x64

Link to the template: Dwarf Door

It’s intended to be the entryway for an underground city. Here’s what it looks like:

It’s intended to be flush with the cliff-face, with a 4x4 tunnel behind the door.

When it’s built out in the open (with no cliff), they finish building it but leave some of the scaffolding. When it’s built against the cliff, they don’t finish it at all.

4 Likes

Here another Build they wont build right
@yshan here is another build for him

For some reason they dont finish floor and also cont to build tops

https://drive.google.com/folderview?id=0B45LtNDFZunhQTNrSG9lT3NCcUk&usp=sharing

1 Like

to bad you have building issue, because i like the build :slight_smile:

1 Like

I posted this for a completely different bug (which wasn’t a bug) before realizing my hearthlings were having trouble building it.

Game’s End Eatery.zip (46.9 KB)

They don’t seem to like the inverted L-shaped chest shelves. The ladder on the left is actually mine, but it unfortunately didn’t help them any. Later I got discovered that you can attach ladders to ghost furniture once the villagers have entered the laying down furniture stage, so I added a ladder to the side and lower front. Lo and behold:

Shelves. I had to add ladders to the front so they can (hopefully) put the upper shelf boxes in, but I was going to have to do that anyway so they could reach said boxes when the eatery was finished, so I’m not terribly bothered. A little annoying that I have to do this after the furniture starts getting put in rather than during the initial design phase, but meh.

They seem like they’re going to be happy to finish it now, although the game’s grinding to a halt and I need to let my computer cool down.

The one out in the open is finished, the hearthlings can’t take the scaffolding down because they can’t reach it, build a 1 block high ladder at the base of each of the bits of scaffolding and they’ll take it down.

The other is stuck because they want to place the blocks in between the cliff and the front lighter grey panel but can’t get there building a ladder so they can walk along the top of the grey front bit might fix this.

I understand how I could work around it, if I choose to. This thread is for sharing builds that the Hearthlings won’t finish.

me again. At this time, the settlers not completed two parts of the building


A similar missing piece on the other side of the house

farm house full.zip (21.6 KB)

1 Like

Hi, I worked on a two-piece building in Alpha 17, build 3023. The hearthlings do not start to build the building, although the materials are in stock. I get this error message when I load the savegame:

develop-3023 (x64)…/fixture_fabricator/fixture_fabricator_component.lua:171: attempt to index local ‘building’ (a nil value)stack traceback:
[C]: ?
…/fixture_fabricator/fixture_fabricator_component.lua:171: in function ‘_are_dependencies_satisfied’
…/fixture_fabricator/fixture_fabricator_component.lua:218: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:42: in function <…/fixture_fabricator/fixture_fabricator_component.lua:40>
develop-3023 (x64)c++ exception: lua runtime errorstack traceback:

I uploaded the template.

Best,
Benmy new building template.zip (51.1 KB)