[A16/A17] The buildings my hearthlings will not build (round 2!)

here is a screenshot of the house wich creates the error, we can see the hole beneeth it, but i have already built 2 other “no floor” house by that way and it worked fine.
we can see the two houses already built behind the big one


Hello @fratermalou, welcome to the forum :slight_smile:

I moved your posts here. Do you have the template of your building?

It should be located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_objects\stonehearth\building_templates

1 Like

Hi everyone
thank you very much, here it is.
I am french, sorry if my english is bad sometimeshouse_bug_forum.zip (9.5 KB)

1 Like

This is likely caused by the fact that (I believe) the code is written that foundations must be dug by hearthlings.

Dug or placed. Basically a foundation to be designated, or well a floor to be designated. Found out that one of my designs that I did like 3 times redoing it from scratch; got the 3rd one to work. How? Make everything on the floor level a floor. Do that before placing slabs above it. Of course also having the wall where wanted before doing that will ensure the walls are in the right place.

In the last thread it was 2 of the last templates I posted, but managed to redo the smaller one.

The main thing I have noticed is the building thingy doesn’t like floors and slabs next to each other in certain situations. Like the half wrap around porch. Works fine if along one side of building, however not so much when on more than 1, if the porch is completely slabs.

Something like that. So I’s imagine yes just not having a foundation of some kind could cause something like that in certain instances. Has to have a first floor before having a second. :slight_smile:

Note: This is just from what I have noticed in my own experience with the building thingy.

ok i will try to build only the floor with slabs and try to build the house in another template

the house is well built. I just filled the hole behind it by stone slabs. and it worked. just some windows and beds remain unplaced but i guess the heartlings will place them later, as they usually do.

Here is a Build to help Chris get Scaffolding working



We’ve got a flush of new problematic template reports with A17, so pinning this back up!


No buildings are completing today, including existing in-game templates. I had no problems last night under develop-2996, but since develop-2998, no buildings are completing.

I have attempted to build several custom build designs and have now tried an in-game template, being the blacksmith house from the tier 2 ascendancy. None of them complete and workers go idle after a while.

When saving, quitting and reloading, I get errors relating to scaffolding, which I’ve copied and pasted below.

Steps to reproduce:

  1. Select the blacksmith house template from ascendancy tier 2.
  2. Build will only partially complete.

Expected Results:
I would expect the building to complete.

Actual Results:
Builders will commence with the foundations and first layer/columns, but will only get so far before stopping and returning to idle.

I have tested whether this is a lack of resources problem, and it’s not. Despite having plentiful wood to complete the construction, it still stalls. Quitting and reloading the game seems to get the build going again, but this only lasts for a minute or two before the builders return to idle.

Potentially relevant error messages:
develop-2998 (x64)
stonehearth/components/scaffolding/scaffolding.lua:228: attempt to index field ‘_blueprint’ (a nil value)
stack traceback:
[C]: ?
stonehearth/components/scaffolding/scaffolding.lua:228: in function 'get_blueprint_region’
stonehearth/components/scaffolding/scaffolding.lua:213: in function 'recalculate_scaffolding_blueprint’
stonehearth/components/scaffolding/scaffolding.lua:123: in function '_add_region_trace’
stonehearth/components/scaffolding/scaffolding.lua:99: in function <stonehearth/components/scaffolding/scaffolding.lua:96>

develop-2998 (x64)
c++ exception: lua runtime error
stack traceback:

develop-2998 (x64)
…hearth/components/scaffolding/scaffolding_region.lua:464: attempt to index field ‘_blueprint’ (a nil value)
stack traceback:
[C]: ?
…hearth/components/scaffolding/scaffolding_region.lua:464: in function ‘get_structure_blueprint_region’
…hearth/components/scaffolding/scaffolding_region.lua:387: in function ‘_add_traces’
…hearth/components/scaffolding/scaffolding_region.lua:170: in function <…hearth/components/scaffolding/scaffolding_region.lua:153>

develop-2998 (x64)
…hearth/components/scaffolding/scaffolding_region.lua:391: bad argument #1 to ‘get_building_for’ (Entity expected, got nil)
stack traceback:
[C]: ?
[C]: in function 'error’
radiant/lib/checks.lua:56: in function 'checks’
stonehearth/lib/build_util.lua:293: in function ‘get_building_for’
…hearth/components/scaffolding/scaffolding_region.lua:391: in function ‘_add_traces’
…hearth/components/scaffolding/scaffolding_region.lua:170: in function <…hearth/components/scaffolding/scaffolding_region.lua:153>


The below image shows the blacksmith house on the left, which I attempted building using the available in-game templates. The building on the right is a simple custom design which has also experienced the same problem. Note that the building on the right took several reloads of the game to get to the point it’s at now. Originally it was just left with a foundation and a single layer of wall blocks.

Version Number and Mods in use:

Unrelated point:
These forums are rather restrictive to new members. I’ve had to create a new account to make this bug post because my existing one won’t allow me to make more than 2 bug posts due to being a “new member”, with the restriction being lifted in a number of hours following the bug posts I made last night. I’m sure you’d rather know about the bugs than turn potential reporters away… I’m also unable to put more than one image in a post. Again, that’s not very helpful when I’m attempting to give thorough information on a bug I’m experiencing!

Don’t know why this won’t build.

claystone sheperds barn 2s.zip (28.7 KB)
This one does not have a single slab even in the build. It is all non-slab. The only thing I can think of is the roof being opposite directions.

This is how far they got before there was not a single pathing even going toward or even to work on the building.

They got the clay brick border of the first floor. The inside floor is made of stone. Wonder if that has to do with it. I just used one of the stone pattern floors. So in essence unlike my other buildings the floor is all in a way default things… Just being a little creative in how I went about the floor, although with this one I didn’t actually design a pattern myself; just default one. So that would be the other guess being 2 different materials & being partially up against that mountain.

Also there has not been a single battle in this particular save. No new spawns since I started A17 (3000) which is today 4 days going on the 5th. I get an error for the first spawn I think. So if you want to see that with the other load up errors:

Just in case, as this is where they stopped in the natural environment they started to build in.

Special Note: I turned the auto-que thing off. I waited until they had built enough of the windows, which was a couple days; they stopped sometime on the first.

have you moved the template so it is not touching the mountain? if so are the still stalling?

They will not build that and for this reason. looking at the back of the build touching the mountain, they Ai assumes that it need to put the scaffolding on the outside. but then they get to the mountain they can not finish the scaff. they will not flip to inside due to fact they did it on the outside. so the only thing i can think of to make them work that build is to babysit the inside by putting ladders up as they build it.

They did not get to scaffolding, as they have not finished the floor. I have not had problems with them building up against a mountain like that; Hence many of the structures all around Sorenia that I have made. As of A16 all structures within the place they have been able to build.

A17 I am confused why they didn’t even start for the most part. Especially when they have not gotten to the scaffolding part. I have a couple of buildings that have been built like that in Sorenia up against a large rock, where there is a gap partially on one side. And yes I had to “babysit” but to me it is more like just helping out.

When they don’t get even that far, then I have to wonder what the actual problem is. Dealing with scaffolding placement and helping them along is the easy part when they get that far. Ladders do wonders.

Maybe I’ll see if I can get them to build it in A16, although unsure if the blueprint would work; since that was made in A17, which means I will have to remake if the case.

Most of my building usually have foundation for the exception of a couple buildings, and when I do one without, this happens; even if the other one worked. I’ll have another look regadless sometime later, but I am sure there is something a bit more to it than scaffolding placement. The stone floor with a clay border might be the problem, but that is just a guess. :slight_smile:

@Doc_Brano Well with this building style I have not had much trouble with this type. Free standing would look odd with what I have in mind… In a way this is technically pushing the building limits. The way I see it, I should be able to build this, as the rest of the town is buildable. I could understand being a bit aways from the rock that is attached to the mountain if it were the wooden roofs or the stone ones, but these clay roofs are generally flat along one side. The little bit of wood sticking out has plenty of room; I made sure of that in the very least. I’ll check later though if free standing will. Even if it can, that just means I have to redesign it so it will build in that specific nook/location.

I Think I have an idea. On reload they started building again. However that particular blueprint does bring up an error every time it is placed.

develop-3000 (x64)
stonehearth/lib/player/territory.lua:56: attempt to index field ‘_structures’ (a nil value)
stack traceback:
[C]: ?
stonehearth/lib/player/territory.lua:56: in function ‘add_entity’
…nehearth/services/server/terrain/terrain_service.lua:124: in function 'added_cb’
radiant/modules/terrain.lua:269: in function <radiant/modules/terrain.lua:267>

I think what stopped my hearthlings from continuing is the simple fact I changed the auto-que in-game; instead of on the main menu. So for that session it just I guess something went wrong. I did that right before starting the building, had it on pause; however I had already clicked build. That is only a guess, as that is all I did. Right between click the build button and unpausing is when I changed that setting.

Still don’t know why there is an engine error, even though the building will be built. I appologize for the long posts and misreading. I guess just mark it for the fact it draws an error when placed down; at least in the 3000 version. Not mentioning no new spawns are happening in that file for some reason, as that itself is drawing an error when something new wants to spawn.

1465686671613.zip (5.5 MB)

This building stopped being built.

@not_owen_wilson @sdee

Unable to build cozy townhouse template within 2 blocks of a fence line or cliff face when the building is positioned such that the internal stairs are closest to the fence/cliff.

I think the problem is that the AI isn’t too good at determining paths vertically, and so instead of using the built part of the stairs to reach the top of the wall and continue building the wall from on top of the wall, the AI keeps looking for ways to build from the sides of blocks only, and when it’s unable to find a valid placement for scaffolding in order to reach the side of a block, the build stalls.

You can see examples of what I mean in the save linked below. I build the same template in a native D3010 new world, one flush up against a cliff, and one that is one block away from the cliff face, and they both stall because of the same basic pathing problem, though I expected the problem to go away once there was one block between the building and the cliff, so perhaps this will help further shed some light?

Anecdotally, I’m not sure why the AI prefers to build things from the external edges of the designs and not try to take full advantage of the interior paths. I’ve seen builds stall because the AI required external pathability, while it could absolutely reach the same spot if it just looked for a route that utilized the interior of the structure. Weird.

1466004272057.zip (4.9 MB)


Note: this post sounds like the same root problem – [A16/A17] The buildings my hearthlings will not build (round 2!)

1 Like

Have several error during the building, few workers stack on walls and my heartlings can’t remove scaffolding after a successful attempt.

harchevna.zip (24.9 KB)



Once they make the crenelations the hearthlings stop working on the rest of the building.

Once they reach the top floor they stop working on the rest of the building.