[A14/A15] The buildings my hearthling will not build Thread

Thanks :slight_smile:
No this building consist of floors, walls, slabs :slight_smile: but all those extra things creating more detail and balcony and roof is all in slab.

1 Like

Im having this problem with a building. they just stop constructing it. its usually when they get to the roof but this time its before. exact same building.

corner house left.zip (39.0 KB)

1 Like

I’m having the same problem again in a different fort where a floor mosaic that places (and builds) normally in most places, will not place itself in an area where it should fit – the game shows it visually as placeable, but when you click to place the template in that spot, it “pops” up thirty-odd feet in the air instead onto the next level. (this time it’s trying to build the mosaic literally thirty feet up in midair, with no support at all).

Do y’all want another savegame on this problem? Or should I post it as a separate bug thread?

Initial attempted placement :

Where it actually goes:

different angle:

(slight differences in background because shots taken during different sessions – tried reloading different game to make it work, save/reload did not fix).

Again, this mosaic does build fine in most locations, it just wont’ fit there for some reason, and I can’t figure out why (neither can the game itself apparently, since visually it’s allowed to place there). There are no buildings above or below it or any other structures that would seemingly be forcing this change. Any tips/thoughts/workarounds appreciated. This is a different fort and unrelated templates from the last time this happened.

edit: this error happens even if I reload a very early save for this map from before I had built or dug anything else at all.

2 Likes

building_templates.zip (45.2 KB)

they didnt finish , and they didnt start the roof yet



1 Like

The first thing to do is check and make sure you have enough wood for scaffolding.

The second thing to do is see if it’s a CPU problem. Pause your game for a couple of minutes and see if they start building again.

Third thing is build a ladder over the top of the existing structure and another ladder down on the inside so that hearthlings can get out. (sometimes this also fixes the building issue, if a hearthling is blocked in and can’t get to the next spot to build, even if that spot is otherwise accessible to other hearthlings).

If those fail reload an earlier save and build the building anew, making sure to do so in the normal view mode (not slice or xray, which can sometimes mess up building).

3 Likes

THNX !!! :slight_smile: it work :slight_smile:

1 Like

However now the last step , two columns ?

i already add laders and still nothing ,

1 Like

i remove old columns and bulid new which works :slight_smile: , Thanks :slight_smile:

1 Like

I wanted to build a defense wall in my new game, but I will not get build even with ib command.
Here is my Save game
1460669238960.zip (8.9 MB)
And here is a screenshot of my GREAT Wall

3 Likes

Go big or go home, man. Love it. :slight_smile:

Anyone figured out what the max vertical range for Archers seems to be, yet? I’m curious just how tall of a tower we can build before they won’t be able to see their prey down below.

2 Likes

Wanted to test how far they could build. and they were sooo close to finishing this castle, I am sad now.
Schloss.zip (6.3 KB)
1461444338625.zip (6.3 MB)

2 Likes

My Archers don’t care at all for the Defend Location command and always try to shoot from the same level…

1 Like

I’m having problems building structures next to each other when they’re connected by a road/path. It’s easy to replicate, just setup two standard house about two blocks away from each other. They should be buildings with walls, floors and roofs. I put doors on mine and then linked them up with a footpath. Suddenly, error.

http://images.akamai.steamusercontent.com/ugc/447356746962571914/F536EB79753106522F0E058E2D02892E07FBBAA9/

It seems to only happen when there’s completed buildings across a particular size… just placing floors and footpaths don’t produce the error log.

I’ve also had problems literally bridging stuff in the game but I’ve literally just patched the latest version that released today and tested this particular problem.

I also plan on testing building buildings right next to each other. I realised that if I create a template, save it and then place two building templates within each other I can cause them to share a single wall. This however didn’t work last time due to the two staircases sharing the wall and the ai failing to path to the centre but I’ll restest again and see if that’s changed.

1 Like

I was about to post a long explanation of a number of buildings I could not get to build, but then I came to this thread and noticed that there’s still a ton of trouble with building in general. I guess I will wait for more development on the building system, but suffice to say so far I’ve had very few buildings actually wind-up building for me to date. =/ Especially anything involving a building with one or more walls attached to it. So many buildings I design, even very simple ones with plenty of space outside around them, either don’t even start getting built or the hearthlings build parts of it (like floor and one wall) and never continue - I’ve ensured abundant materials nearby and all windows/doors already crafted, still nothing.

I’ve also tried pausing construction and editing then restarting construction with SOME amount of success (i.e. they proceeded to build one more wall of the structure before giving up again) but it always winds-up in a dead jam at some point. And I can never delete/remove these aborted projects, they are permanently stuck in my games. I will try to get a save or two demonstrating some issues posted here, but I honestly have formed a habit of saving my game right before a build and reverting back when/if it fails. =/

1 Like

Well I really aught to hold back a little when i have trouble with the editor.

That is as far as they got, then they refused it seemed to finish. It might be due to a hole in the floor that is covered in the pic, but that hole is a result of having trouble with the editor. Was suppose to become part of the build, but the 2x2x2 wood piece refused to become part of it, and also I could not for some reason delete any piece of it with the eraser tool. So that is the reason for the 2x2 hole that is under the floor.

Another thing is that this building is raised 1 block off the ground, so that might be it, but they got this far didn’t they? Side note when I initially set to build it all that showed up was the overhang and building floating in the area and they were happy to be building that, even if there was more to the structure than than. The ghost image didn’t show the rest that I build, so effectively the rest of the bits disappeared; which were the slab pieces that vanished.

Insta build works as well the template saving. So that was good that the template system functioned properly otherwise I would not be able to put forth the file; and yes the icon for it is along with the template this time. Loving that part of the system finally that yall got that in. :slight_smile:

clay wood dorm with porch 3s.zip (30.4 KB)

That is the template and icon preview. Don’t know why they exactly didn’t finish, but have my guesses. Which relate to above mentioned areas. Scaffolding is the most awkward thing in this one, as they are obviously putting many in places they would not be able to get to afterwards, as well excessive, as seen in the first pic.

Hope this helps for future building tuning. :slight_smile:

Special note: This Was in A16 (The one before 2951)

1 Like

Ok I redesigned the above with not much trouble in the actual building editor process this time. It happens to be a somewhat smaller building than the one above. A16 2960


The ib look of what it is suppose to be.


The first pic just shows the odd ladder placement during the process, while the second pic shows how far they did get before they stopped building completely. Also the second pic is a second attempt at building and they did get 1 block further. I placed the template down to see if it was just initial construction causing problems or the building itself. I think you can guess where my conclusion ended up being.

claywood fancy dorm porch3s .zip (27.1 KB)

Note:
–Overhang roof to cover porch.
–Beams that connect the top of wall to outside porch wall
–Foundation up 3 blocks, the 3rd being where the floor is.
–Only Floor where the actual building is, hence the missing segment in pic.
–Odd ladder placement. Both sides of porch wall having ladders.
–Only main building is not slabs.

I am thinking it might have to be similar to why the blacksmith one I posted here didn’t build. Where the floor is both with the floor tool and slab. As in portion of floor is slab only, while the rest (main building) was slab first and floor laid afterwards.

So on end it is mainly the actual building didn’t build with slabs attached. Only most of the slab construction was built.

I don’t think you will need the save file, but here it is just in case.
Teoloria00.zip (7.0 MB)

Summary:
Hearthlings get stuck in an infinite loop whilst building check save
Steps to reproduce:

  1. unsure, maybe build a lot of buildings

Expected Results:
the hearthlings to just build the building
Actual Results:
they spend all there time walking up one ladder then down, up a second ladder then down and then repeat.
Notes:

Attachments:
1463242964119.zip (6.0 MB)
Version Number and Mods in use:
2972 no mods
System Information:

@8BitCrab can you merge this with buildings my hearthlings won’t build, wasn’t thinking and should have put this in there :slight_smile: thanks

1 Like

This topic has been archived - no changes of any kind (including edits) are allowed. This topic has been in place for over 10 months, and many templates included now build!

Alpha 17 will be focusing on building again, so if you find templates that do not complete, require manual ladder placement, or have scaffolding that isn’t removed, please post them in the new topic:

http://discourse.stonehearth.net/t/a16-the-buildings-my-hearthlings-will-not-build-round-2/22200